LibreOffice remote via WebDAV poortnummer?

Probeer in LibreOffice rechtstreeks file op te slaan/te bewerken in cloud.nubo. Welk poortnummer moet ik gebruiken, of lukt dit enkel via NextCloud?
Op Ubuntu server 20.04.1 met Mate desktop environment.
Screenshot at 2022-01-06 06-30-45

1 Like

Van wat ik hier al gelezen heb is de gemakkelijkste manier om een lokale dir op je computer te syncen naar nextcloud en dan gewoon te saven naar die dir.

https://docs.nextcloud.com/desktop/2.3/installing.html

Als je toch rechtstreeks wil saven naar nextcloud dan kan dit in libreoffice zo (niet zelf getest):
https://help.libreoffice.org/6.1/he/text/shared/guide/digitalsign_receive.html

Je moet hier wel een app paswoord voor aanmaken:
https://cloud.nubo.coop/settings/user/security

2 Likes

(Vertaling door DeepL, sorry voor eventuele onnauwkeurigheden)

Hallo,

Ik heb nog nooit geprobeerd om direct met WebDAV in LibreOffice te werken, ik heb het zojuist geprobeerd en het werkt als volgt:

  • Host: cloud.nubo.coop
  • Poort: 443 *
  • Beveiligde verbinding: ja *
  • Root: /remote.php/dav/files/<Nubo-Username>/

Wachtwoord : zoals @robbie zegt (bedankt voor het antwoord dat me hielp om het te proberen !), je moet hier een applicatiewachtwoord aanmaken : https://cloud.nubo.coop/settings/user/security

* Ik heb het verschillende keren geprobeerd, het is mogelijk dat je de eerste keer de poort 80 moet verlaten (?)

Bewerken in LibreOffice (7.2.3.2) leek niet erg stabiel, dus ik weet niet of ik deze methode zou aanbevelen, maar het is goed om te weten. (Andere methoden: met de sync client of bewerken in de browser).

En français (original)

Bonjour,

Je n’avais jamais essayé avant de travailler directement en WebDAV dans LibreOffice, je viens d’essayer et j’y suis arrivé comme ceci :

  • Hôte : cloud.nubo.coop
  • Port : 443 *
  • Connexion sécurisée : oui *
  • Racine : /remote.php/dav/files/<Nubo-Username>/

Mot de passe : comme le dit @robbie (merci pour la réponse qui m’a aidé à essayer !), il faut créer un mot de passe d’application ici : https://cloud.nubo.coop/settings/user/security

* J’ai essayé plusieurs fois, c’est possible que la première fois il faut laisser le port 80 (?)

L’édition dans LibreOffice (7.2.3.2) ne m’a pas semblé très stable, donc je ne sais pas si je recommanderai cette méthode, mais c’est bon à savoir. (Autres méthodes : passer par le client de synchronisation ou éditer dans le navigateur.)

1 Like

Hello !

After setting an app-password on my account, I followed those instructions to use the WebDAV access within Keyweb (to access Keypass files stored on my Nubo). I end up with an error (“Error: network error”).

In order to check if that issue comes from Keyweb, I tried to use the WebDAV access with the software “Transmit” (which I use for FTP transfers since 10 years). And… it doesn’t work either : “SSL handshake failed: SSL error: tlsv1 alert protocol version”.

Connection settings & error message :
Capture d’écran 2022-01-22 à 16.55.03

Capture d’écran 2022-01-22 à 16.54.27

Does anyone know why it would fail to connect ?

Thanks :slight_smile:
Simon.

I see “SSL error: tlsv1”, I’ll ask @quenenni

Juste to be sure, you used the application password in Transmit ?

Otherwise it looks like an outdated version of SSL/TLS (the server does not accept TLS versions under 1.2). I think you are usinge macOS, right? Is it an old version?

Can you copy-paste this line in a terminal, then press enter, and copy the result here? It’ll show the TLS version on your computer.
python -c "import urllib2; import json; print(json.loads(urllib2.urlopen('https://www.howsmyssl.com/a/check').read())['tls_version'])"

And same thing with this one too (for SSL version):
python -c "import ssl; print(ssl.OPENSSL_VERSION)"

Hello Emmanuel,
Thank you for your help !

Yes.
I just checked it again to make sure (actually, I tried with the account password too, and the result is the same).

The 1rst code calls this answer :
TLS 1.2

And with the 2nd code :
LibreSSL 2.8.3

Have a nice evening,
Simon.

Hello Simon,

I see LibreSSL v2.8.3 is from 15-Dec-2018.
That’s a bit old.

Could you try to update it?
The last version is v3.4.2 (25-Nov-2021)

I checked again to acces via Webdav and had no problem on my side.
Let’s see what happen after you updated LibreSSL.
There were lots of improvements (and bugs found and fixed) in SSL world in 3 years.

Best,
Kenny

Hello Kenny,
Sorry you died so many times !
Thank you very much for your reply :pray:

Yes, I just updated it !
I’m now able to mount the webDAV directory through the Finder.
Still not working with Transmit nor Keyweb (same error messages), but I suppose that it isn’t related to Nubo, so the agora may not be the right place to solve this.

As it wasn’t that easy to understand how to update LibreSSL on Mac OS X 12.0.1, I wrote down how to do it (for further use) :

  • through the terminal, using Homebrew to resintall openssl as explained here until the “Symbolic link” part (which doesn’t work) :
$ /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
$ brew install openssl
  • Then, read the end of install logs and apply the command needed in order to create the symbolic link. Otherwise, the old version will still be used (solution described here). The part to copy and paste is within the single quotes. It would look as this (bold text is what we’re looking for) :

libressl is keg-only, which means it was not symlinked into /usr/local,
because macOS already provides this software and installing another version in
parallel can cause all kinds of trouble.

If you need to have libressl first in your PATH, run:
echo ‘export PATH="/usr/local/opt/libressl/bin:$PATH"’ >> ~/.profile

Simon.

Excellent.
Thanks Simon for the tip to update LibreSsl.

Did you restart your computer after the libreSsl update?
It’s a possibility, small, but still one, that Transmit or Keeweb are still using the old version.
Theoriqually, they shouldn’t, but in practical, sometimes it’s needed.
I.E., Transmit and Keeweb load a SSL database when they start, so they loaded the old version. And they didn’t reload the database after your updated LibreSSL.

If it’s still not working, can you do a new test and send me by private msg the time of your attempt and your ip address (you can see it here: Adresse Ip)
I’ll go check the log see if I can find something there (low chance, but better than no chance)

Kenny.

Sadly, I did restart the computer before checking with Transmit and Keyweb.
I will do as you suggest, which closes this public discussion :wink: