Partage de dossiers / Sharing folders

, , , ,

:fr: Je souhaite partager un dossier entre mon compte principal et un compte lié que j’ai créé. Pour cela, j’ai accédé aux paramètres de partage du dossier et cherché le compte cible dans le champ dédié. Cependant, le compte cible est introuvable. Ai-je manqué quelque chose ou bien s’agit-il d’un bug ?

:uk: I’d like to share a folder between my account and a linked account I created. To do so, I accessed the sharing parameters of the folder and searched for the target account using the dedicated field. However, the target account account could not be found. Did I miss something, or is this a bug?

:netherlands: [DeepL] Ik wil een map delen tussen mijn hoofdaccount en een gekoppelde account die ik heb aangemaakt. Om dit te doen, ging ik naar de instellingen voor delen van de map en zocht naar de doelaccount in het daarvoor bestemde veld. De doelrekening kan echter niet worden gevonden. Mis ik iets of is dit een bug?

Did you add the second account to the contacts of the main account?

Yes I did; still the contact shows up in the share menu as a link share target (see this Nextcloud blog post for link vs internal sharing).

Salut,

Les autres comptes Nubo, mêmes liés, ne sont pas proposés automatiquement pour le partage interne.

Par contre, il devrait être possible d’utiliser le partage fédéré en utilisant son “identifiant de Cloud Fédéré” du type « identifiant@cloud.nubo.coop » que vous pouvez trouver là : https://cloud.nubo.coop/settings/user/sharing

Mais, pour ma part, j’ai un bug avec ça pour l’instant. Quand vous mettez identifiant@cloud.nubo.coop dans le partage, il devrait proposer deux choses :
a. identifiant@cloud.nubo.coop + image enveloppe
b. “identifiant sur cloud.nubo.coop

image
(Ici, “idnubo” devrait être un identifiant Nubo. C’est une image pour l’exemple, montrant ce qu’on devrait voir.)

Avec (a), il propose d’envoyer un e-mail, mais ça ne marchera pas parce que c’est un identifiant de cloud fédéré et pas une adresse e-mail. Et donc c’est normalement (b) qui active le partage interne au cloud.

Lors des quelques tests que j’ai faits, il ne me proposait pas (b) pour les clouds Nubo existants. C’est un problème que j’ai remonté au service technique, mais qui n’est pas encore résolu. Je suppose que c’est un problème pour tout le monde, mais je n’ai pas eu d’autres retours pour l’instant.

Vertaling DeepL

Hoi,

Andere Nubo-accounts, zelfs gekoppelde, worden niet voorgesteld in de lijst van contacten voor intern delen.

Aan de andere kant zou het mogelijk moeten zijn om de federated sharing te gebruiken door zijn “Federated Cloud ID” van het type “identifiant@cloud.nubo.coop” te gebruiken, die u hier kunt vinden: https://cloud.nubo.coop/settings/user/sharing

Maar, voor mijn part, heb ik daar een bug mee voor nu. Als je identifiant@cloud.nubo.coop in het aandeel stopt, moet het twee dingen aanbieden:
a. identifiant@cloud.nubo.coop + enveloppe afbeelding
b. “inloggen op cloud.nubo.coop

image
(Hier moet “idnubo” een Nubo ID zijn. Dit is een afbeelding voor het voorbeeld, die laat zien wat we zouden moeten zien).

Met (a), biedt het aan om een e-mail te sturen, maar dat zal niet werken omdat het een gefedereerde cloud ID is en geen e-mail adres. En dus is het normaal gesproken (b) dat de interne cloud sharing activeert.

In de paar tests die ik deed, bood het me (b) niet aan voor bestaande Nubo wolken. Dit probleem heb ik doorgegeven aan de technische ondersteuning, maar het is nog niet opgelost. Ik neem aan dat dit een probleem is voor iedereen, maar ik heb nog geen andere feedback gehad.

Translation DeepL

Hi,

The other Nubo accounts, even if linked, are not proposed in the list of contacts for internal sharing.

On the other hand, it should be possible to use the federated sharing by using its “Federated Cloud ID” of the type “identifiant@cloud.nubo.coop” that you can find here: https://cloud.nubo.coop/settings/user/sharing

But, for my part, I have a bug with this for now. When you put identifiant@cloud.nubo.coop in the share, it should offer two things:
a. identifiant@cloud.nubo.coop + envelope image
b. “login to cloud.nubo.coop

image
(Here, “idnubo” should be a Nubo ID. This is an image for the example, showing what we should see).

With (a), it offers to send an email, but that won’t work because it’s a federated cloud ID and not an email address. And so it’s normally (b) that activates the internal cloud sharing.

In the few tests I did, it wouldn’t offer me (b) for existing Nubo clouds. This is an issue I’ve escalated to tech support, but it’s not resolved yet. I’m assuming this is an issue for everyone, but I haven’t had any other feedback yet.

1 Like

Si vous ne l’avez pas encore fait, n’hésitez pas a essayer un partage avec l’identifiant de cloud fédéré du compte (https://cloud.nubo.coop/settings/user/sharing), mais si ça ne fonctionne pas, il faudra attendre la résolution du bug…

(DeepL) If you haven’t done it yet, feel free to try sharing with the account’s federated cloud ID (https://cloud.nubo.coop/settings/user/sharing), but if it doesn’t work, you’ll have to wait until the bug is fixed…

(DeepL) Als u dat nog niet gedaan hebt, probeer dan te delen met de federated cloud ID van de account (https://cloud.nubo.coop/settings/user/sharing), maar als dat niet werkt, zult u moeten wachten tot de bug verholpen is…

:clipperton_island: Merci pour cette réponse, c’est très clair. J’ai essayé la procédure de partage par identifiant de cloud fédéré et cela ne semble malheureusement pas fonctionner pour l’instant.

:uk: Thanks for your answer, it’s very clear. I tried the federated cloud ID-based sharing procedure and it seems that it does unfortunately not work at the moment.

Bonjour,

Y a une solution pour ça, mais il semblerait que ce soit encore un peu buggé.

Je m’occupe de corriger ton compte pour que ça marche et d’aller vérifier notre procédure.

Je reviens vers toi un peu plus tard.

Bien à toi,
Kenny

1 Like

Est-ce que tu peux ré-essayer de partager un dossier avec l’utilisateur du compte associé et me dire si c’est bon maintenant?

Merci,
Kenny

J’ai refait un essai.

Du côté du compte principal [leroyvn] :

  • le champ de recherche ne m’affiche pas le compte lié si je le cherche par son seul identifiant local ou cloud fédéré (@cloud.nubo.coop) ;
  • je le trouve si je le cherche avec l’adresse e-mail (@nubo.coop) ;
  • le partage échoue (voir message ci-après).

La situation est symétrique du côté du compte lié [kolevskadz].


Message d’erreur

Erreur à la création du partage : Le partage de Test folder a échoué, impossible de trouver vincent.leroy@nubo.coop, le serveur est peut-être momentanément injoignable ou utilise un certificat auto-signé.


PS : j’ai remarqué que Nextcloud a un système de groupes d’utilisateurs, Nubo supporte-t-il cette fonctionnalité ?

Est-ce que tu pourrais re-tester, mais bien te déconnecter du Nextcloud et te reco.
J’ai oublié de te préciser ça. Et si tu ne le fais pas, il ne vas pas prendre en compte tes nouveaux groupes.

j’ai remarqué que Nextcloud a un système de groupes d’utilisateurs, Nubo supporte-t-il cette fonctionnalité ?
Tout à fait. C’est le système interne à Nextcloud que nous utilisons.

Ça fonctionne, tout va bien ! Je pense qu’on peut clore le sujet, merci beaucoup !

  1. De mon côté, je ne parviens pas non-plus à partager entre compte principal et sous-compte (ici : partage d’agenda). Il ne propose ni (a) ni (b) :
    Capture d’écran 2022-01-28 à 18.05.33

  2. J’ai également essayé en créant un contact dans le compte principal, contenant l’ID fédéré du sous-compte, et vice-versa. Quand j’entre les premières lettres du contact, rien n’apparaît.

  3. Enfin, je ne parviens pas non-plus à partager vers une adresse e-mail quelle qu’elle soit.

Est-ce que ceci correspond au bug dont il est question plus haut ?
Merci pour votre aide :slight_smile:
K.

Salut,

Ça ne correspond pas tout à fait, parce que maintenant, je pense qu’il devrait être au moins possible de faire le partage avec les comptes liés, en tout cas chez moi ça fonctionne. @quenenni, est-ce que ça devrait marcher pour tout le monde ?

Pour le partage par courriel, il faut d’abord créer un lien de partage (cliquer sur image puis sur le “+”) et une fois que le lien de partage est créé, cliquer sur les “…” à côté du lien de partage et là il y a “Envoyer le lien vers l’agenda par courriel”.

Bonjour kirmaha,

Y a en effet un petit problème à ce niveau.

Quand on crée un sous-compte, on met automatiquement le compte et le sous-compte dans un même groupe du Cloud.

Cela permet de pouvoir partager facilement fichiers / carnets d’adresses / agendas entre les différents utilisateurs du compte / sous-comptes.

Il s’avère que ses groupes n’ont pas été créés pour ton compte.

Je vous les ai ajouté.
Il vous faut vous déconnecter / reconnecter pour que ce soit pris en compte.

Bien à toi,
Kenny

Ca c’est bizarre.
Je viens de tester et je n’ai pas eu de soucis.

Tu peux me dire comment tu as essayé ça?

Kenny

Bonjour à tous les deux et merci pour vos réponses !

Je viens de tester avec le partage de fichiers, le partage d’agenda et le partage de carnet d’adresse. Tout semble fonctionnel (partage strictement en interne, sans utiliser l’ID Cloud Fédéré, et sans avoir à créer le contact auquel faisait référence Robbie).
Merci beaucoup !

Je viens de réessayer et ça fonctionne correctement… J’avais probablement fait une fausse manoeuvre, désolé :face_with_hand_over_mouth:

Bonne soirée et encore merci !
K.

A post was split to a new topic: Partage d’agenda entre comptes Nubo